テスト

らびブログ

2022年 2021年 2020年 2019年

[Android] Could not find com.android.tools.build:gradle:2.2.3.

Android Studio を 2.3 にバージョンアップしたところ以下の様なエラーが出ました。
Error:A problem occurred configuring root project 'PasswordMaker'.
> Could not resolve all dependencies for configuration ':classpath'.
   > Could not find com.android.tools.build:gradle:2.2.3.
     Searched in the following locations:
         file:/C:/WinApp/android-studio/gradle/m2repository/com/android/tools/build/gradle/2.2.3/gradle-2.2.3.pom
         file:/C:/WinApp/android-studio/gradle/m2repository/com/android/tools/build/gradle/2.2.3/gradle-2.2.3.jar
         https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.3/gradle-2.2.3.pom
         https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.3/gradle-2.2.3.jar
     Required by:
         :PasswordMaker:unspecified
C:\WinApp\android-studio\gradle\m2repository\com\android\tools\build\gradle には、"2.2.0" と "2.3.0" のフォルダーがありましたので、 build.gradle を
        classpath 'com.android.tools.build:gradle:2.3.0'
と、書き換えたところエラーが無くなりました。

[Android] AdMobで追加されるライブラリ

Android Studio の「1:Project」で「Project」を選択で表示される「External Libraries」について、 build.gradle で AdMob を以下の様に追加すると、
    compile 'com.google.android.gms:play-services-ads-lite:10.2.0'
以下が追加されました。
play-services-ads-lite-10.2.0 play-services-basement-10.2.0 support-annotations-24.0.0 support-v4-24.0.0 この時のアプリのsupport-v4ライブラリの最新版は、
    compile 'com.android.support:support-v4:25.2.0'
なので少し古い版が使われている様です。
テスト
©2017-2022 RabiSoft